TableSplitControl Namespace

[image]

.NET Framework Class Library
TableSplitControl Namespace
Send Feedback

Classes

Class | Description
ColumnStyle | Стиль столбцов TableSplitPanel.
RowStyle | Стиль строк TableSplitPanel.
Style | Базовый класс стилей строк/столбцов TableSplitPanel.
TableCellPanel | Класс, предназначенный для отображения одной ячейки элемента управления TableSplitPanel.
TableSplitPanel | Элемент управления, аналогичный TableLayoutPanel, предназначенный для отображения дочерних элементов управления в табличном виде, а также для интерактивного изменения размеров строк и столбцов табличного вида.

Enumerations

Enumeration | Description
SizeMode | Режимы задания начального размера для строк и столбцов TableSplitPanel.
Send feedback on this topic to Microsoft.


ColumnStyle Class

[image]

.NET Framework Class Library
ColumnStyle Class
Members See Also Send Feedback

Стиль столбцов TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnStyle _
    Inherits Style
C#
public sealed class ColumnStyle : Style
Visual C++
public ref class ColumnStyle sealed : public Style
JavaScript
TableSplitControl.ColumnStyle = function();

Type.createClass(
    'TableSplitControl.ColumnStyle',
    TableSplitControl.Style);

Inheritance Hierarchy

System..::.Object
TableSplitControl..::.Style
TableSplitControl..::.ColumnStyle

See Also

ColumnStyle Members
TableSplitControl Namespace


ColumnStyle Members

[image] [image]

.NET Framework Class Library
ColumnStyle Members
ColumnStyle Class Constructors Methods Fields See Also Send Feedback

The ColumnStyle type exposes the following members.

Constructors

Name | Description
ColumnStyle | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel. (Inherited from Style.)
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}. (Inherited from Style.)

See Also

ColumnStyle Class


ColumnStyle Constructor

[image] [image]

.NET Framework Class Library
ColumnStyle Constructor
ColumnStyle Class See Also Send Feedback

Overload List

Name | Description
ColumnStyle()()() | Создать экземпляр класса, описывающего стиль столбца TableSplitPanel, используя значение по-умолчанию: Default (автоматический режим).
ColumnStyle(SizeMode, Double) | Создать экземпляр класса, описывающего стиль столбца TableSplitPanel.

See Also

ColumnStyle Class
ColumnStyle Members


ColumnStyle Constructor

[image]

.NET Framework Class Library
ColumnStyle Constructor
ColumnStyle Class See Also Send Feedback

Создать экземпляр класса, описывающего стиль столбца TableSplitPanel, используя значение по-умолчанию: Default (автоматический режим).

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ColumnStyle()
Visual C++
public:
ColumnStyle()
JavaScript
TableSplitControl.ColumnStyle = function();

See Also

ColumnStyle Class
ColumnStyle Overload


ColumnStyle Constructor (SizeMode, Double)

[image]

.NET Framework Class Library
ColumnStyle Constructor (SizeMode, Double)
ColumnStyle Class See Also Send Feedback

Создать экземпляр класса, описывающего стиль столбца TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    mode As SizeMode, _
    value As Double _
)
C#
public ColumnStyle(
    SizeMode mode,
    double value
)
Visual C++
public:
ColumnStyle(
    SizeMode mode,
    double value
)
JavaScript
TableSplitControl.ColumnStyle = function(mode, value);

Parameters

mode
Type: TableSplitControl..::.SizeMode
Режим задания начального размера.
value
Type: System..::.Double
Значение доли относительно ширины TableSplitPanel.

See Also

ColumnStyle Class
ColumnStyle Overload


ColumnStyle Fields

[image] [image]

.NET Framework Class Library
ColumnStyle Fields
ColumnStyle Class See Also Send Feedback

The ColumnStyle type exposes the following members.

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel. (Inherited from Style.)
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}. (Inherited from Style.)

See Also

ColumnStyle Class


ColumnStyle Methods

[image] [image]

.NET Framework Class Library
ColumnStyle Methods
ColumnStyle Class See Also Send Feedback

The ColumnStyle type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

ColumnStyle Class


RowStyle Class

[image]

.NET Framework Class Library
RowStyle Class
Members See Also Send Feedback

Стиль строк TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RowStyle _
    Inherits Style
C#
public sealed class RowStyle : Style
Visual C++
public ref class RowStyle sealed : public Style
JavaScript
TableSplitControl.RowStyle = function();

Type.createClass(
    'TableSplitControl.RowStyle',
    TableSplitControl.Style);

Inheritance Hierarchy

System..::.Object
TableSplitControl..::.Style
TableSplitControl..::.RowStyle

See Also

RowStyle Members


RowStyle Members

[image] [image]

.NET Framework Class Library
RowStyle Members
RowStyle Class Constructors Methods Fields See Also Send Feedback

The RowStyle type exposes the following members.

Constructors

Name | Description
RowStyle | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel. (Inherited from Style.)
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}. (Inherited from Style.)

See Also

RowStyle Class


RowStyle Constructor

[image] [image]

.NET Framework Class Library
RowStyle Constructor
RowStyle Class See Also Send Feedback

Overload List

Name | Description
RowStyle()()() | Создать экземпляр класса, описывающего стиль строки TableSplitPanel, используя значение по-умолчанию: Default (автоматический режим).
RowStyle(SizeMode, Double) | Создать экземпляр класса, описывающего стиль строки TableSplitPanel.

See Also

RowStyle Class
RowStyle Members


RowStyle Constructor

[image]

.NET Framework Class Library
RowStyle Constructor
RowStyle Class See Also Send Feedback

Создать экземпляр класса, описывающего стиль строки TableSplitPanel, используя значение по-умолчанию: Default (автоматический режим).

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RowStyle()
Visual C++
public:
RowStyle()
JavaScript
TableSplitControl.RowStyle = function();

See Also

RowStyle Class
RowStyle Overload


RowStyle Constructor (SizeMode, Double)

[image]

.NET Framework Class Library
RowStyle Constructor (SizeMode, Double)
RowStyle Class See Also Send Feedback

Создать экземпляр класса, описывающего стиль строки TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    mode As SizeMode, _
    value As Double _
)
C#
public RowStyle(
    SizeMode mode,
    double value
)
Visual C++
public:
RowStyle(
    SizeMode mode,
    double value
)
JavaScript
TableSplitControl.RowStyle = function(mode, value);

Parameters

mode
Type: TableSplitControl..::.SizeMode
Режим задания начального размера.
value
Type: System..::.Double
Значение доли относительно высоты TableSplitPanel.

See Also

RowStyle Class
RowStyle Overload


RowStyle Fields

[image] [image]

.NET Framework Class Library
RowStyle Fields
RowStyle Class See Also Send Feedback

The RowStyle type exposes the following members.

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel. (Inherited from Style.)
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}. (Inherited from Style.)

See Also

RowStyle Class


RowStyle Methods

[image] [image]

.NET Framework Class Library
RowStyle Methods
RowStyle Class See Also Send Feedback

The RowStyle type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RowStyle Class


SizeMode Enumeration

[image]

.NET Framework Class Library
SizeMode Enumeration
See Also Send Feedback

Режимы задания начального размера для строк и столбцов TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SizeMode
C#
public enum SizeMode
Visual C++
public enum class SizeMode
JavaScript
TableSplitControl.SizeMode = function();
TableSplitControl.SizeMode.createEnum('TableSplitControl.SizeMode', false);

Members

Member name | Description
Default | Автоматический (пропорциональный).
Relative | С указанной долей относительно размера TableSplitPanel в данном направлении.

See Also

TableSplitControl Namespace
Send feedback on this topic to Microsoft.


Style Class

[image]

.NET Framework Class Library
Style Class
Members See Also Send Feedback

Базовый класс стилей строк/столбцов TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Style
C#
public abstract class Style
Visual C++
public ref class Style abstract
JavaScript
TableSplitControl.Style = function();

Type.createClass(
    'TableSplitControl.Style');

Inheritance Hierarchy

System..::.Object
TableSplitControl..::.Style
TableSplitControl..::.ColumnStyle
TableSplitControl..::.RowStyle

See Also

Style Members


Style Members

[image] [image]

.NET Framework Class Library
Style Members
Style Class Methods Fields See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel.
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}.

See Also

Style Class


Style Fields

[image] [image]

.NET Framework Class Library
Style Fields
Style Class See Also Send Feedback

The Style type exposes the following members.

Fields

Name | Description
Mode | Режим задания начального размера для строк и столбцов TableSplitPanel.
Value | Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}.

See Also

Style Class


Mode Field

[image]

.NET Framework Class Library
Style..::.Mode Field
Style Class See Also Send Feedback

Режим задания начального размера для строк и столбцов TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Mode As SizeMode
C#
public readonly SizeMode Mode
Visual C++
public:
initonly SizeMode Mode
JavaScript
mode

See Also

Style Class


Value Field

[image]

.NET Framework Class Library
Style..::.Value Field
Style Class See Also Send Feedback

Значение доли относительно размера TableSplitPanel в данном направлении. Должно быть в диапазоне {0.0 - 1.0}.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As Double
C#
public readonly double Value
Visual C++
public:
initonly double Value
JavaScript
value

See Also

Style Class


Style Methods

[image] [image]

.NET Framework Class Library
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Style Class


TableCellPanel Class

[image]

.NET Framework Class Library
TableCellPanel Class
Members See Also Send Feedback

Класс, предназначенный для отображения одной ячейки элемента управления TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Class TableCellPanel _
    Inherits Panel
C#
public class TableCellPanel : Panel
Visual C++
public ref class TableCellPanel : public Panel
JavaScript
TableSplitControl.TableCellPanel = function();

Type.createClass(
    'TableSplitControl.TableCellPanel',
    Panel);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.Panel
TableSplitControl..::.TableCellPanel

See Also

TableCellPanel Members


TableCellPanel Members

[image] [image]

.NET Framework Class Library
TableCellPanel Members
TableCellPanel Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The TableCellPanel type exposes the following members.

Constructors

Name | Description
TableCellPanel | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | (Inherited from Control.)
Contains | (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Control.)
CreateControl | (Inherited from Control.)
CreateControlsInstance | (Inherited from Control.)
CreateGraphics | (Inherited from Control.)
CreateHandle | (Inherited from Control.)
CreateObjRef | (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Control.)
DestroyHandle | (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | (Inherited from Control.)
DrawToBitmap | (Inherited from Control.)
EndInvoke | (Inherited from Control.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Component.)
FindForm | (Inherited from Control.)
Focus | (Inherited from Control.)
GetAccessibilityObjectById | (Inherited from Control.)
GetAutoSizeMode | (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | (Inherited from Control.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetNextControl | (Inherited from Control.)
GetPreferredSize | (Inherited from Control.)
GetScaledBounds | (Inherited from Control.)
GetScrollState | (Inherited from ScrollableControl.)
GetService | (Inherited from Component.)
GetStyle | (Inherited from Control.)
GetTopLevel | (Inherited from Control.)
GetType | (Inherited from Object.)
Hide | (Inherited from Control.)
InitializeLifetimeService | (Inherited from MarshalByRefObject.)
InitLayout | (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | (Inherited from Control.)
InvokeLostFocus | (Inherited from Control.)
InvokeOnClick | (Inherited from Control.)
InvokePaint | (Inherited from Control.)
InvokePaintBackground | (Inherited from Control.)
IsInputChar | (Inherited from Control.)
IsInputKey | (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | (Inherited from Control.)
OnAutoSizeChanged | (Inherited from Control.)
OnBackColorChanged | (Inherited from Control.)
OnBackgroundImageChanged | (Inherited from Control.)
OnBackgroundImageLayoutChanged | (Inherited from Control.)
OnBindingContextChanged | (Inherited from Control.)
OnCausesValidationChanged | (Inherited from Control.)
OnChangeUICues | (Inherited from Control.)
OnClick | (Inherited from Control.)
OnClientSizeChanged | (Inherited from Control.)
OnContextMenuChanged | (Inherited from Control.)
OnContextMenuStripChanged | (Inherited from Control.)
OnControlAdded | (Inherited from Control.)
OnControlRemoved | (Inherited from Control.)
OnCreateControl | (Inherited from Control.)
OnCursorChanged | (Inherited from Control.)
OnDockChanged | (Inherited from Control.)
OnDoubleClick | (Inherited from Control.)
OnDragDrop | (Inherited from Control.)
OnDragEnter | (Inherited from Control.)
OnDragLeave | (Inherited from Control.)
OnDragOver | (Inherited from Control.)
OnEnabledChanged | (Inherited from Control.)
OnEnter | (Inherited from Control.)
OnFontChanged | (Inherited from Control.)
OnForeColorChanged | (Inherited from Control.)
OnGiveFeedback | (Inherited from Control.)
OnGotFocus | (Inherited from Control.)
OnHandleCreated | (Inherited from Control.)
OnHandleDestroyed | (Inherited from Control.)
OnHelpRequested | (Inherited from Control.)
OnImeModeChanged | (Inherited from Control.)
OnInvalidated | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyPress | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLayout | (Inherited from ScrollableControl.)
OnLeave | (Inherited from Control.)
OnLocationChanged | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMarginChanged | (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from Control.)
OnMouseClick | (Inherited from Control.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseHover | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseUp | (Inherited from Control.)
OnMouseWheel | (Inherited from ScrollableControl.)
OnMove | (Inherited from Control.)
OnNotifyMessage | (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | (Inherited from Control.)
OnParentBackgroundImageChanged | (Inherited from Control.)
OnParentBindingContextChanged | (Inherited from Control.)
OnParentChanged | (Inherited from Control.)
OnParentCursorChanged | (Inherited from Control.)
OnParentEnabledChanged | (Inherited from Control.)
OnParentFontChanged | (Inherited from Control.)
OnParentForeColorChanged | (Inherited from Control.)
OnParentRightToLeftChanged | (Inherited from Control.)
OnParentVisibleChanged | (Inherited from Control.)
OnPreviewKeyDown | (Inherited from Control.)
OnPrint | (Inherited from Control.)
OnQueryContinueDrag | (Inherited from Control.)
OnRegionChanged | (Inherited from Control.)
OnResize | (Inherited from Panel.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | (Inherited from ScrollableControl.)
OnSizeChanged | (Inherited from Control.)
OnStyleChanged | (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Control.)
OnTabIndexChanged | (Inherited from Control.)
OnTabStopChanged | (Inherited from Control.)
OnTextChanged | (Inherited from Control.)
OnValidated | (Inherited from Control.)
OnValidating | (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformLayout | Overloaded.
PointToClient | (Inherited from Control.)
PointToScreen | (Inherited from Control.)
PreProcessControlMessage | (Inherited from Control.)
PreProcessMessage | (Inherited from Control.)
ProcessCmdKey | (Inherited from Control.)
ProcessDialogChar | (Inherited from Control.)
ProcessDialogKey | (Inherited from Control.)
ProcessKeyEventArgs | (Inherited from Control.)
ProcessKeyMessage | (Inherited from Control.)
ProcessKeyPreview | (Inherited from Control.)
ProcessMnemonic | (Inherited from Control.)
RaiseDragEvent | (Inherited from Control.)
RaiseKeyEvent | (Inherited from Control.)
RaiseMouseEvent | (Inherited from Control.)
RaisePaintEvent | (Inherited from Control.)
RecreateHandle | (Inherited from Control.)
RectangleToClient | (Inherited from Control.)
RectangleToScreen | (Inherited from Control.)
Refresh | (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | (Inherited from Control.)
RtlTranslateHorizontal | (Inherited from Control.)
RtlTranslateLeftRight | (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | (Inherited from ScrollableControl.)
ScrollToControl | (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | (Inherited from Control.)
SendToBack | (Inherited from Control.)
SetAutoScrollMargin | (Inherited from ScrollableControl.)
SetAutoSizeMode | (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Control.)
SetClientSizeCore | (Inherited from Control.)
SetDisplayRectLocation | (Inherited from ScrollableControl.)
SetScrollState | (Inherited from ScrollableControl.)
SetStyle | (Inherited from Control.)
SetTopLevel | (Inherited from Control.)
SetVisibleCore | (Inherited from Control.)
Show | (Inherited from Control.)
SizeFromClientSize | (Inherited from Control.)
SuspendLayout | (Inherited from Control.)
ToString | (Inherited from Panel.)
Update | (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | (Inherited from Control.)
UpdateZOrder | (Inherited from Control.)
WndProc | (Inherited from ScrollableControl.)

Fields

Name | Description
CaptionBar | Служебная панель для отображения заголовка Caption и кнопки максимизации ячейки.

Properties

Name | Description
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
AllowDrop | (Inherited from Control.)
Anchor | (Inherited from Control.)
AutoScroll | (Inherited from ScrollableControl.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Panel.)
AutoSizeMode | (Inherited from Panel.)
BackColor | (Inherited from Control.)
BackgroundImage | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BindingContext | (Inherited from Control.)
BorderStyle | (Inherited from Panel.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Caption | Заголовок ячейки.
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Control.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
Controls | (Inherited from Control.)
Created | (Inherited from Control.)
CreateParams | (Inherited from Panel.)
Cursor | (Inherited from Control.)
DataBindings | (Inherited from Control.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Control.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Panel.)
DesignMode | (Inherited from Component.)
DisplayRectangle | (Inherited from ScrollableControl.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoubleBuffered | (Inherited from Control.)
Enabled | (Inherited from Control.)
Events | (Inherited from Component.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
Handle | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
ImeMode | (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsMirrored | (Inherited from Control.)
LayoutEngine | (Inherited from Control.)
Left | (Inherited from Control.)
Location | (Inherited from Control.)
Margin | (Inherited from Control.)
MaximumSize | (Inherited from Control.)
MinimumSize | (Inherited from Control.)
Name | (Inherited from Control.)
Padding | (Inherited from Control.)
Parent | (Inherited from Control.)
PreferredSize | (Inherited from Control.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
Region | (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | (Inherited from Control.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
ScaleChildren | (Inherited from Control.)
ShowFocusCues | (Inherited from Control.)
ShowKeyboardCues | (Inherited from Control.)
Site | (Inherited from Control.)
Size | (Inherited from Control.)
TabIndex | (Inherited from Control.)
TabStop | (Inherited from Panel.)
Tag | (Inherited from Control.)
Text | (Inherited from Panel.)
Top | (Inherited from Control.)
TopLevelControl | (Inherited from Control.)
UseWaitCursor | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from Panel.)
BackColorChanged | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BindingContextChanged | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientSizeChanged | (Inherited from Control.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlRemoved | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
Disposed | (Inherited from Component.)
DockChanged | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
Enter | (Inherited from Control.)
FontChanged | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HelpRequested | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
Invalidated | (Inherited from Control.)
KeyDown | (Inherited from Panel.)
KeyPress | (Inherited from Panel.)
KeyUp | (Inherited from Panel.)
Layout | (Inherited from Control.)
Leave | (Inherited from Control.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MarginChanged | (Inherited from Control.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
Resize | (Inherited from Control.)
RightToLeftChanged | (Inherited from Control.)
Scroll | (Inherited from ScrollableControl.)
SizeChanged | (Inherited from Control.)
StyleChanged | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndexChanged | (Inherited from Control.)
TabStopChanged | (Inherited from Control.)
TextChanged | (Inherited from Panel.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TableCellPanel Class


TableCellPanel Constructor

[image] [image]

.NET Framework Class Library
TableCellPanel Constructor
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
TableCellPanel(Control) | Создать экземпляр класса TableCellPanel.
TableCellPanel(Control, BorderStyle) | Создать экземпляр класса TableCellPanel

See Also

TableCellPanel Class
TableCellPanel Members


TableCellPanel Constructor (Control)

[image]

.NET Framework Class Library
TableCellPanel Constructor (Control)
TableCellPanel Class See Also Send Feedback

Создать экземпляр класса TableCellPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    control As Control _
)
C#
public TableCellPanel(
    Control control
)
Visual C++
public:
TableCellPanel(
    Control^ control
)
JavaScript
TableSplitControl.TableCellPanel = function(control);

Parameters

control
Type: System.Windows.Forms..::.Control
Содержимое ячейки.

See Also

TableCellPanel Class
TableCellPanel Overload


TableCellPanel Constructor (Control, BorderStyle)

[image]

.NET Framework Class Library
TableCellPanel Constructor (Control, BorderStyle)
TableCellPanel Class See Also Send Feedback

Создать экземпляр класса TableCellPanel

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    control As Control, _
    borderStyle As BorderStyle _
)
C#
public TableCellPanel(
    Control control,
    BorderStyle borderStyle
)
Visual C++
public:
TableCellPanel(
    Control^ control,
    BorderStyle borderStyle
)
JavaScript
TableSplitControl.TableCellPanel = function(control, borderStyle);

Parameters

control
Type: System.Windows.Forms..::.Control
Содержимое ячейки.
borderStyle
Type: System.Windows.Forms..::.BorderStyle
Стиль границы ячейки.

See Also

TableCellPanel Class
TableCellPanel Overload


TableCellPanel Fields

[image] [image]

.NET Framework Class Library
TableCellPanel Fields
TableCellPanel Class See Also Send Feedback

The TableCellPanel type exposes the following members.

Fields

Name | Description
CaptionBar | Служебная панель для отображения заголовка Caption и кнопки максимизации ячейки.

See Also

TableCellPanel Class


CaptionBar Field

[image]

.NET Framework Class Library
TableCellPanel..::.CaptionBar Field
TableCellPanel Class See Also Send Feedback

Служебная панель для отображения заголовка Caption и кнопки максимизации ячейки.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly CaptionBar As Panel
C#
public readonly Panel CaptionBar
Visual C++
public:
initonly Panel^ CaptionBar
JavaScript
captionBar

See Also

TableCellPanel Class


TableCellPanel Methods

[image] [image]

.NET Framework Class Library
TableCellPanel Methods
TableCellPanel Class See Also Send Feedback

The TableCellPanel type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ScrollableControl.)
BeginInvoke | Overloaded.
BringToFront | (Inherited from Control.)
Contains | (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Control.)
CreateControl | (Inherited from Control.)
CreateControlsInstance | (Inherited from Control.)
CreateGraphics | (Inherited from Control.)
CreateHandle | (Inherited from Control.)
CreateObjRef | (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Control.)
DestroyHandle | (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | (Inherited from Control.)
DrawToBitmap | (Inherited from Control.)
EndInvoke | (Inherited from Control.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Component.)
FindForm | (Inherited from Control.)
Focus | (Inherited from Control.)
GetAccessibilityObjectById | (Inherited from Control.)
GetAutoSizeMode | (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | (Inherited from Control.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetNextControl | (Inherited from Control.)
GetPreferredSize | (Inherited from Control.)
GetScaledBounds | (Inherited from Control.)
GetScrollState | (Inherited from ScrollableControl.)
GetService | (Inherited from Component.)
GetStyle | (Inherited from Control.)
GetTopLevel | (Inherited from Control.)
GetType | (Inherited from Object.)
Hide | (Inherited from Control.)
InitializeLifetimeService | (Inherited from MarshalByRefObject.)
InitLayout | (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | (Inherited from Control.)
InvokeLostFocus | (Inherited from Control.)
InvokeOnClick | (Inherited from Control.)
InvokePaint | (Inherited from Control.)
InvokePaintBackground | (Inherited from Control.)
IsInputChar | (Inherited from Control.)
IsInputKey | (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | (Inherited from Control.)
OnAutoSizeChanged | (Inherited from Control.)
OnBackColorChanged | (Inherited from Control.)
OnBackgroundImageChanged | (Inherited from Control.)
OnBackgroundImageLayoutChanged | (Inherited from Control.)
OnBindingContextChanged | (Inherited from Control.)
OnCausesValidationChanged | (Inherited from Control.)
OnChangeUICues | (Inherited from Control.)
OnClick | (Inherited from Control.)
OnClientSizeChanged | (Inherited from Control.)
OnContextMenuChanged | (Inherited from Control.)
OnContextMenuStripChanged | (Inherited from Control.)
OnControlAdded | (Inherited from Control.)
OnControlRemoved | (Inherited from Control.)
OnCreateControl | (Inherited from Control.)
OnCursorChanged | (Inherited from Control.)
OnDockChanged | (Inherited from Control.)
OnDoubleClick | (Inherited from Control.)
OnDragDrop | (Inherited from Control.)
OnDragEnter | (Inherited from Control.)
OnDragLeave | (Inherited from Control.)
OnDragOver | (Inherited from Control.)
OnEnabledChanged | (Inherited from Control.)
OnEnter | (Inherited from Control.)
OnFontChanged | (Inherited from Control.)
OnForeColorChanged | (Inherited from Control.)
OnGiveFeedback | (Inherited from Control.)
OnGotFocus | (Inherited from Control.)
OnHandleCreated | (Inherited from Control.)
OnHandleDestroyed | (Inherited from Control.)
OnHelpRequested | (Inherited from Control.)
OnImeModeChanged | (Inherited from Control.)
OnInvalidated | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyPress | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLayout | (Inherited from ScrollableControl.)
OnLeave | (Inherited from Control.)
OnLocationChanged | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMarginChanged | (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from Control.)
OnMouseClick | (Inherited from Control.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseHover | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseUp | (Inherited from Control.)
OnMouseWheel | (Inherited from ScrollableControl.)
OnMove | (Inherited from Control.)
OnNotifyMessage | (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | (Inherited from Control.)
OnParentBackgroundImageChanged | (Inherited from Control.)
OnParentBindingContextChanged | (Inherited from Control.)
OnParentChanged | (Inherited from Control.)
OnParentCursorChanged | (Inherited from Control.)
OnParentEnabledChanged | (Inherited from Control.)
OnParentFontChanged | (Inherited from Control.)
OnParentForeColorChanged | (Inherited from Control.)
OnParentRightToLeftChanged | (Inherited from Control.)
OnParentVisibleChanged | (Inherited from Control.)
OnPreviewKeyDown | (Inherited from Control.)
OnPrint | (Inherited from Control.)
OnQueryContinueDrag | (Inherited from Control.)
OnRegionChanged | (Inherited from Control.)
OnResize | (Inherited from Panel.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | (Inherited from ScrollableControl.)
OnSizeChanged | (Inherited from Control.)
OnStyleChanged | (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Control.)
OnTabIndexChanged | (Inherited from Control.)
OnTabStopChanged | (Inherited from Control.)
OnTextChanged | (Inherited from Control.)
OnValidated | (Inherited from Control.)
OnValidating | (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformLayout | Overloaded.
PointToClient | (Inherited from Control.)
PointToScreen | (Inherited from Control.)
PreProcessControlMessage | (Inherited from Control.)
PreProcessMessage | (Inherited from Control.)
ProcessCmdKey | (Inherited from Control.)
ProcessDialogChar | (Inherited from Control.)
ProcessDialogKey | (Inherited from Control.)
ProcessKeyEventArgs | (Inherited from Control.)
ProcessKeyMessage | (Inherited from Control.)
ProcessKeyPreview | (Inherited from Control.)
ProcessMnemonic | (Inherited from Control.)
RaiseDragEvent | (Inherited from Control.)
RaiseKeyEvent | (Inherited from Control.)
RaiseMouseEvent | (Inherited from Control.)
RaisePaintEvent | (Inherited from Control.)
RecreateHandle | (Inherited from Control.)
RectangleToClient | (Inherited from Control.)
RectangleToScreen | (Inherited from Control.)
Refresh | (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | (Inherited from Control.)
RtlTranslateHorizontal | (Inherited from Control.)
RtlTranslateLeftRight | (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | (Inherited from ScrollableControl.)
ScrollToControl | (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | (Inherited from Control.)
SendToBack | (Inherited from Control.)
SetAutoScrollMargin | (Inherited from ScrollableControl.)
SetAutoSizeMode | (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Control.)
SetClientSizeCore | (Inherited from Control.)
SetDisplayRectLocation | (Inherited from ScrollableControl.)
SetScrollState | (Inherited from ScrollableControl.)
SetStyle | (Inherited from Control.)
SetTopLevel | (Inherited from Control.)
SetVisibleCore | (Inherited from Control.)
Show | (Inherited from Control.)
SizeFromClientSize | (Inherited from Control.)
SuspendLayout | (Inherited from Control.)
ToString | (Inherited from Panel.)
Update | (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | (Inherited from Control.)
UpdateZOrder | (Inherited from Control.)
WndProc | (Inherited from ScrollableControl.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TableCellPanel Class


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.AccessibilityNotifyClients Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


BeginInvoke Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.BeginInvoke Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


Dispose Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.Dispose Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.GetChildAtPoint Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


Invalidate Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.Invalidate Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | (Inherited from Control.)
Invalidate(Region) | (Inherited from Control.)
Invalidate(Boolean) | (Inherited from Control.)
Invalidate(Rectangle) | (Inherited from Control.)
Invalidate(Region, Boolean) | (Inherited from Control.)
Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


Invoke Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.Invoke Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.MemberwiseClone Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

TableCellPanel Class
TableCellPanel Members


PerformLayout Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.PerformLayout Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | (Inherited from Control.)
PerformLayout(Control, String) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


ResumeLayout Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.ResumeLayout Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Control.)
ResumeLayout(Boolean) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.RtlTranslateAlignment Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


Scale Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.Scale Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


Select Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.Select Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
Select()()() | (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


SetBounds Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.SetBounds Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


UpdateBounds Method

[image] [image]

.NET Framework Class Library
TableCellPanel..::.UpdateBounds Method
TableCellPanel Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

TableCellPanel Class
TableCellPanel Members


TableCellPanel Properties

[image] [image]

.NET Framework Class Library
TableCellPanel Properties
TableCellPanel Class See Also Send Feedback

The TableCellPanel type exposes the following members.

Properties

Name | Description
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
AllowDrop | (Inherited from Control.)
Anchor | (Inherited from Control.)
AutoScroll | (Inherited from ScrollableControl.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Panel.)
AutoSizeMode | (Inherited from Panel.)
BackColor | (Inherited from Control.)
BackgroundImage | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BindingContext | (Inherited from Control.)
BorderStyle | (Inherited from Panel.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Caption | Заголовок ячейки.
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Control.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
Controls | (Inherited from Control.)
Created | (Inherited from Control.)
CreateParams | (Inherited from Panel.)
Cursor | (Inherited from Control.)
DataBindings | (Inherited from Control.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Control.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Panel.)
DesignMode | (Inherited from Component.)
DisplayRectangle | (Inherited from ScrollableControl.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoubleBuffered | (Inherited from Control.)
Enabled | (Inherited from Control.)
Events | (Inherited from Component.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
Handle | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
ImeMode | (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsMirrored | (Inherited from Control.)
LayoutEngine | (Inherited from Control.)
Left | (Inherited from Control.)
Location | (Inherited from Control.)
Margin | (Inherited from Control.)
MaximumSize | (Inherited from Control.)
MinimumSize | (Inherited from Control.)
Name | (Inherited from Control.)
Padding | (Inherited from Control.)
Parent | (Inherited from Control.)
PreferredSize | (Inherited from Control.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
Region | (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | (Inherited from Control.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
ScaleChildren | (Inherited from Control.)
ShowFocusCues | (Inherited from Control.)
ShowKeyboardCues | (Inherited from Control.)
Site | (Inherited from Control.)
Size | (Inherited from Control.)
TabIndex | (Inherited from Control.)
TabStop | (Inherited from Panel.)
Tag | (Inherited from Control.)
Text | (Inherited from Panel.)
Top | (Inherited from Control.)
TopLevelControl | (Inherited from Control.)
UseWaitCursor | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TableCellPanel Class


Caption Property

[image]

.NET Framework Class Library
TableCellPanel..::.Caption Property
TableCellPanel Class See Also Send Feedback

Заголовок ячейки.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Property Caption As String
C#
public string Caption { get; set; }
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_caption();
function set_caption(value);

See Also

TableCellPanel Class


TableCellPanel Events

[image] [image]

.NET Framework Class Library
TableCellPanel Events
TableCellPanel Class See Also Send Feedback

The TableCellPanel type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from Panel.)
BackColorChanged | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BindingContextChanged | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientSizeChanged | (Inherited from Control.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlRemoved | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
Disposed | (Inherited from Component.)
DockChanged | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
Enter | (Inherited from Control.)
FontChanged | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HelpRequested | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
Invalidated | (Inherited from Control.)
KeyDown | (Inherited from Panel.)
KeyPress | (Inherited from Panel.)
KeyUp | (Inherited from Panel.)
Layout | (Inherited from Control.)
Leave | (Inherited from Control.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MarginChanged | (Inherited from Control.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
Resize | (Inherited from Control.)
RightToLeftChanged | (Inherited from Control.)
Scroll | (Inherited from ScrollableControl.)
SizeChanged | (Inherited from Control.)
StyleChanged | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndexChanged | (Inherited from Control.)
TabStopChanged | (Inherited from Control.)
TextChanged | (Inherited from Panel.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)

See Also

TableCellPanel Class


TableSplitPanel Class

[image]

.NET Framework Class Library
TableSplitPanel Class
Members Example See Also Send Feedback

Элемент управления, аналогичный TableLayoutPanel, предназначенный для отображения дочерних элементов управления в табличном виде, а также для интерактивного изменения размеров строк и столбцов табличного вида.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Class TableSplitPanel _
    Inherits ContainerControl
C#
public class TableSplitPanel : ContainerControl
Visual C++
public ref class TableSplitPanel : public ContainerControl
JavaScript
TableSplitControl.TableSplitPanel = function();

Type.createClass(
    'TableSplitControl.TableSplitPanel',
    ContainerControl);

Examples

Пример использования этого элемента управления.
C# Copy Code
using System.Windows.Forms;
using TableSplitControl;

namespace TestForm
{
public partial class Form1 : Form
    {
        private readonly TableSplitPanel table;

        public Form1()
        {
            InitializeComponent();

            SuspendLayout();

            // На форме есть 4 контрола, которые нужно вставить в TableSplitPanel.
            // Соберем их в массив 2x2:
            Control[,] controls = new Control[2, 2] {{groupControl1, panelControl1}, {groupControl2, labelControl1}};

            // Удаляем собранные контролы с формы
            Controls.Remove(groupControl1);
            Controls.Remove(panelControl1);
            Controls.Remove(groupControl2);
            Controls.Remove(labelControl1);

            // Вызовем конструктор TableSplitPanel
            table = new TableSplitPanel(controls,
                new TableSplitControl.RowStyle[] { new TableSplitControl.RowStyle(SizeMode.Relative, 0.2), new TableSplitControl.RowStyle() },
                new TableSplitControl.ColumnStyle[] { new TableSplitControl.ColumnStyle(SizeMode.Relative, 0.4), new TableSplitControl.ColumnStyle() },
                BorderStyle.Fixed3D);
            table.Dock = DockStyle.Fill;

            // Можно задать названия панелей
            table.Panels[0, 0].Caption = "aasdasd";
            table.Panels[1, 0].Caption = "Панель";
            table.Panels[1, 1].Caption = "Контрол";
             // Добавим TableSplitPanel на форму.
            Controls.Add(table);

            ResumeLayout();
        }
    }
}

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
TableSplitControl..::.TableSplitPanel

See Also

TableSplitPanel Members
TableSplitControl Namespace
System.Windows.Forms..::.TableLayoutPanel


TableSplitPanel Members

[image] [image]

.NET Framework Class Library
TableSplitPanel Members
TableSplitPanel Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The TableSplitPanel type exposes the following members.

Constructors

Name | Description
TableSplitPanel | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | (Inherited from Control.)
Contains | (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Control.)
CreateControl | (Inherited from Control.)
CreateControlsInstance | (Inherited from Control.)
CreateGraphics | (Inherited from Control.)
CreateHandle | (Inherited from Control.)
CreateObjRef | (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Control.)
DestroyHandle | (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | (Inherited from Control.)
DrawToBitmap | (Inherited from Control.)
EndInvoke | (Inherited from Control.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Component.)
FindForm | (Inherited from Control.)
Focus | (Inherited from Control.)
ForEach | Цикл по всем ячейкам.
GetAccessibilityObjectById | (Inherited from Control.)
GetAutoSizeMode | (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | (Inherited from Control.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetNextControl | (Inherited from Control.)
GetPreferredSize | (Inherited from Control.)
GetScaledBounds | (Inherited from Control.)
GetScrollState | (Inherited from ScrollableControl.)
GetService | (Inherited from Component.)
GetStyle | (Inherited from Control.)
GetTopLevel | (Inherited from Control.)
GetType | (Inherited from Object.)
Hide | (Inherited from Control.)
InitializeLifetimeService | (Inherited from MarshalByRefObject.)
InitLayout | (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | (Inherited from Control.)
InvokeLostFocus | (Inherited from Control.)
InvokeOnClick | (Inherited from Control.)
InvokePaint | (Inherited from Control.)
InvokePaintBackground | (Inherited from Control.)
IsInputChar | (Inherited from Control.)
IsInputKey | (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | (Inherited from Control.)
OnAutoSizeChanged | (Inherited from Control.)
OnAutoValidateChanged | (Inherited from ContainerControl.)
OnBackColorChanged | (Inherited from Control.)
OnBackgroundImageChanged | (Inherited from Control.)
OnBackgroundImageLayoutChanged | (Inherited from Control.)
OnBindingContextChanged | (Inherited from Control.)
OnCausesValidationChanged | (Inherited from Control.)
OnChangeUICues | (Inherited from Control.)
OnClick | (Inherited from Control.)
OnClientSizeChanged | (Inherited from Control.)
OnContextMenuChanged | (Inherited from Control.)
OnContextMenuStripChanged | (Inherited from Control.)
OnControlAdded | (Inherited from Control.)
OnControlRemoved | (Inherited from Control.)
OnCreateControl | (Inherited from ContainerControl.)
OnCursorChanged | (Inherited from Control.)
OnDockChanged | (Inherited from Control.)
OnDoubleClick | (Inherited from Control.)
OnDragDrop | (Inherited from Control.)
OnDragEnter | (Inherited from Control.)
OnDragLeave | (Inherited from Control.)
OnDragOver | (Inherited from Control.)
OnEnabledChanged | (Inherited from Control.)
OnEnter | (Inherited from Control.)
OnFontChanged | (Inherited from ContainerControl.)
OnForeColorChanged | (Inherited from Control.)
OnGiveFeedback | (Inherited from Control.)
OnGotFocus | (Inherited from Control.)
OnHandleCreated | (Inherited from Control.)
OnHandleDestroyed | (Inherited from Control.)
OnHelpRequested | (Inherited from Control.)
OnImeModeChanged | (Inherited from Control.)
OnInvalidated | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyPress | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | (Inherited from Control.)
OnLocationChanged | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMarginChanged | (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from Control.)
OnMouseClick | (Inherited from Control.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseHover | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseUp | (Inherited from Control.)
OnMouseWheel | (Inherited from ScrollableControl.)
OnMove | (Inherited from Control.)
OnNotifyMessage | (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | (Inherited from Control.)
OnParentBackgroundImageChanged | (Inherited from Control.)
OnParentBindingContextChanged | (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | (Inherited from Control.)
OnParentEnabledChanged | (Inherited from Control.)
OnParentFontChanged | (Inherited from Control.)
OnParentForeColorChanged | (Inherited from Control.)
OnParentRightToLeftChanged | (Inherited from Control.)
OnParentVisibleChanged | (Inherited from Control.)
OnPreviewKeyDown | (Inherited from Control.)
OnPrint | (Inherited from Control.)
OnQueryContinueDrag | (Inherited from Control.)
OnRegionChanged | (Inherited from Control.)
OnResize | (Inherited from Control.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | (Inherited from ScrollableControl.)
OnSizeChanged | (Inherited from Control.)
OnStyleChanged | (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Control.)
OnTabIndexChanged | (Inherited from Control.)
OnTabStopChanged | (Inherited from Control.)
OnTextChanged | (Inherited from Control.)
OnValidated | (Inherited from Control.)
OnValidating | (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | (Inherited from Control.)
PointToScreen | (Inherited from Control.)
PreProcessControlMessage | (Inherited from Control.)
PreProcessMessage | (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | (Inherited from Control.)
ProcessKeyMessage | (Inherited from Control.)
ProcessKeyPreview | (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | (Inherited from ContainerControl.)
RaiseDragEvent | (Inherited from Control.)
RaiseKeyEvent | (Inherited from Control.)
RaiseMouseEvent | (Inherited from Control.)
RaisePaintEvent | (Inherited from Control.)
RecreateHandle | (Inherited from Control.)
RectangleToClient | (Inherited from Control.)
RectangleToScreen | (Inherited from Control.)
Refresh | (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | (Inherited from Control.)
RtlTranslateHorizontal | (Inherited from Control.)
RtlTranslateLeftRight | (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | (Inherited from ScrollableControl.)
ScrollToControl | (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | (Inherited from Control.)
SendToBack | (Inherited from Control.)
SetAutoScrollMargin | (Inherited from ScrollableControl.)
SetAutoSizeMode | (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Control.)
SetClientSizeCore | (Inherited from Control.)
SetDisplayRectLocation | (Inherited from ScrollableControl.)
SetScrollState | (Inherited from ScrollableControl.)
SetStyle | (Inherited from Control.)
SetTopLevel | (Inherited from Control.)
SetVisibleCore | (Inherited from Control.)
Show | (Inherited from Control.)
SizeFromClientSize | (Inherited from Control.)
SuspendLayout | (Inherited from Control.)
ToString | (Inherited from Component.)
Update | (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | (Inherited from ContainerControl.)
UpdateStyles | (Inherited from Control.)
UpdateZOrder | (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from ContainerControl.)

Fields

Name | Description
Panels | Двумерный массив панелей, каждый элемент которого представляет собой 1 ячейку (класс TableCellPanel). Первый индекс в массиве - индекс столбца, второй - строки.

Properties

Name | Description
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
ActiveControl | (Inherited from ContainerControl.)
AllowDrop | (Inherited from Control.)
Anchor | (Inherited from Control.)
AutoScaleDimensions | (Inherited from ContainerControl.)
AutoScaleFactor | (Inherited from ContainerControl.)
AutoScaleMode | (Inherited from ContainerControl.)
AutoScroll | (Inherited from ScrollableControl.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Control.)
AutoValidate | (Inherited from ContainerControl.)
BackColor | (Inherited from Control.)
BackgroundImage | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Control.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
Controls | (Inherited from Control.)
Created | (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Cursor | (Inherited from Control.)
DataBindings | (Inherited from Control.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Control.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Control.)
DesignMode | (Inherited from Component.)
DisplayRectangle | (Inherited from ScrollableControl.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoubleBuffered | (Inherited from Control.)
Enabled | (Inherited from Control.)
Events | (Inherited from Component.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
Handle | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
ImeMode | (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsMirrored | (Inherited from Control.)
LayoutEngine | (Inherited from Control.)
Left | (Inherited from Control.)
Location | (Inherited from Control.)
Margin | (Inherited from Control.)
MaximumSize | (Inherited from Control.)
MinimumSize | (Inherited from Control.)
Name | (Inherited from Control.)
Padding | (Inherited from Control.)
Parent | (Inherited from Control.)
ParentForm | (Inherited from ContainerControl.)
PreferredSize | (Inherited from Control.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
Region | (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | (Inherited from Control.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
ScaleChildren | (Inherited from Control.)
ShowFocusCues | (Inherited from Control.)
ShowKeyboardCues | (Inherited from Control.)
Site | (Inherited from Control.)
Size | (Inherited from Control.)
SplitterColor | Цвет фона элементов управления splitter, разделяющих строки и столбцы ячеек.
SplitterDragColor | Цвет (в момент перетаскивания) элементов управления splitter, разделяющих строки и столбцы ячеек.
TabIndex | (Inherited from Control.)
TabStop | (Inherited from Control.)
Tag | (Inherited from Control.)
Text | (Inherited from Control.)
Top | (Inherited from Control.)
TopLevelControl | (Inherited from Control.)
UseWaitCursor | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from Control.)
AutoValidateChanged | (Inherited from ContainerControl.)
BackColorChanged | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BindingContextChanged | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientSizeChanged | (Inherited from Control.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlRemoved | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
Disposed | (Inherited from Component.)
DockChanged | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
Enter | (Inherited from Control.)
FontChanged | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HelpRequested | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
Invalidated | (Inherited from Control.)
KeyDown | (Inherited from Control.)
KeyPress | (Inherited from Control.)
KeyUp | (Inherited from Control.)
Layout | (Inherited from Control.)
Leave | (Inherited from Control.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MarginChanged | (Inherited from Control.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
Resize | (Inherited from Control.)
RightToLeftChanged | (Inherited from Control.)
Scroll | (Inherited from ScrollableControl.)
SizeChanged | (Inherited from Control.)
StyleChanged | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndexChanged | (Inherited from Control.)
TabStopChanged | (Inherited from Control.)
TextChanged | (Inherited from Control.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TableSplitPanel Class


TableSplitPanel Constructor

[image] [image]

.NET Framework Class Library
TableSplitPanel Constructor
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
TableSplitPanel(array<Control,2>[,](,)[,]) | Создать новый экземпляр класса TableSplitPanel.
TableSplitPanel(array<TableCellPanel,2>[,](,)[,]) | Создать новый экземпляр класса TableSplitPanel.
TableSplitPanel(array<Control,2>[,](,)[,], BorderStyle) | Создать новый экземпляр класса TableSplitPanel.
TableSplitPanel(array<Control,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[]) | Создать новый экземпляр класса TableSplitPanel.
TableSplitPanel(array<TableCellPanel,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[]) | Создать новый экземпляр класса TableSplitPanel.
TableSplitPanel(array<Control,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[], BorderStyle) | Создать новый экземпляр класса TableSplitPanel.

See Also

TableSplitPanel Class
TableSplitPanel Members


TableSplitPanel Constructor (Control[,])

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<Control,2>[,](,)[,])
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    controls As Control(,) _
)
C#
public TableSplitPanel(
    Control[,] controls
)
Visual C++
public:
TableSplitPanel(
    array<Control^,2>^ controls
)
JavaScript
TableSplitControl.TableSplitPanel = function(controls);

Parameters

controls
Type: array< System.Windows.Forms..::.Control ,2>[,](,)[,]
Двумерный массив элементов управления, каждый элемент которого представляет собой содержимое одной ячейки. Первый индекс в массиве - индекс столбца, второй - строки.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Constructor (TableCellPanel[,])

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<TableCellPanel,2>[,](,)[,])
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    panels As TableCellPanel(,) _
)
C#
public TableSplitPanel(
    TableCellPanel[,] panels
)
Visual C++
public:
TableSplitPanel(
    array<TableCellPanel^,2>^ panels
)
JavaScript
TableSplitControl.TableSplitPanel = function(panels);

Parameters

panels
Type: array< TableSplitControl..::.TableCellPanel ,2>[,](,)[,]
Двумерный массив панелей, каждый элемент которого представляет собой 1 ячейку. Первый индекс в массиве - индекс столбца, второй - строки.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Constructor (Control[,], BorderStyle)

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<Control,2>[,](,)[,], BorderStyle)
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    controls As Control(,), _
    cellsBorderStyle As BorderStyle _
)
C#
public TableSplitPanel(
    Control[,] controls,
    BorderStyle cellsBorderStyle
)
Visual C++
public:
TableSplitPanel(
    array<Control^,2>^ controls,
    BorderStyle cellsBorderStyle
)
JavaScript
TableSplitControl.TableSplitPanel = function(controls, cellsBorderStyle);

Parameters

controls
Type: array< System.Windows.Forms..::.Control ,2>[,](,)[,]
Двумерный массив элементов управления, каждый элемент которого представляет собой содержимое одной ячейки. Первый индекс в массиве - индекс столбца, второй - строки.
cellsBorderStyle
Type: System.Windows.Forms..::.BorderStyle
Стиль границы ячеек.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Constructor (Control[,], RowStyle[], ColumnStyle[])

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<Control,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[])
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    controls As Control(,), _
    rowStyles As RowStyle(), _
    colStyles As ColumnStyle() _
)
C#
public TableSplitPanel(
    Control[,] controls,
    RowStyle[] rowStyles,
    ColumnStyle[] colStyles
)
Visual C++
public:
TableSplitPanel(
    array<Control^,2>^ controls,
    array<RowStyle^>^ rowStyles,
    array<ColumnStyle^>^ colStyles
)
JavaScript
TableSplitControl.TableSplitPanel = function(controls, rowStyles, colStyles);

Parameters

controls
Type: array< System.Windows.Forms..::.Control ,2>[,](,)[,]
Двумерный массив элементов управления, каждый элемент которого представляет собой содержимое одной ячейки. Первый индекс в массиве - индекс столбца, второй - строки.
rowStyles
Type: array< TableSplitControl..::.RowStyle >[]()[]
Начальные значения относительной высоты строк.
colStyles
Type: array< TableSplitControl..::.ColumnStyle >[]()[]
Начальные значения относительной ширины столбцов.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Constructor (TableCellPanel[,], RowStyle[], ColumnStyle[])

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<TableCellPanel,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[])
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    panels As TableCellPanel(,), _
    rowStyles As RowStyle(), _
    colStyles As ColumnStyle() _
)
C#
public TableSplitPanel(
    TableCellPanel[,] panels,
    RowStyle[] rowStyles,
    ColumnStyle[] colStyles
)
Visual C++
public:
TableSplitPanel(
    array<TableCellPanel^,2>^ panels,
    array<RowStyle^>^ rowStyles,
    array<ColumnStyle^>^ colStyles
)
JavaScript
TableSplitControl.TableSplitPanel = function(panels, rowStyles, colStyles);

Parameters

panels
Type: array< TableSplitControl..::.TableCellPanel ,2>[,](,)[,]
Двумерный массив панелей, каждый элемент которого представляет собой 1 ячейку. Первый индекс в массиве - индекс столбца, второй - строки.
rowStyles
Type: array< TableSplitControl..::.RowStyle >[]()[]
Начальные значения относительной высоты строк.
colStyles
Type: array< TableSplitControl..::.ColumnStyle >[]()[]
Начальные значения относительной ширины столбцов.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Constructor (Control[,], RowStyle[], ColumnStyle[], BorderStyle)

[image]

.NET Framework Class Library
TableSplitPanel Constructor (array<Control,2>[,](,)[,], array<RowStyle>[]()[], array<ColumnStyle>[]()[], BorderStyle)
TableSplitPanel Class See Also Send Feedback

Создать новый экземпляр класса TableSplitPanel.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    controls As Control(,), _
    rowStyles As RowStyle(), _
    colStyles As ColumnStyle(), _
    cellsBorderStyle As BorderStyle _
)
C#
public TableSplitPanel(
    Control[,] controls,
    RowStyle[] rowStyles,
    ColumnStyle[] colStyles,
    BorderStyle cellsBorderStyle
)
Visual C++
public:
TableSplitPanel(
    array<Control^,2>^ controls,
    array<RowStyle^>^ rowStyles,
    array<ColumnStyle^>^ colStyles,
    BorderStyle cellsBorderStyle
)
JavaScript
TableSplitControl.TableSplitPanel = function(controls, rowStyles, colStyles, cellsBorderStyle);

Parameters

controls
Type: array< System.Windows.Forms..::.Control ,2>[,](,)[,]
Двумерный массив элементов управления, каждый элемент которого представляет собой содержимое одной ячейки. Первый индекс в массиве - индекс столбца, второй - строки.
rowStyles
Type: array< TableSplitControl..::.RowStyle >[]()[]
Начальные значения относительной высоты строк.
colStyles
Type: array< TableSplitControl..::.ColumnStyle >[]()[]
Начальные значения относительной ширины столбцов.
cellsBorderStyle
Type: System.Windows.Forms..::.BorderStyle
Стиль границы ячеек.

See Also

TableSplitPanel Class
TableSplitPanel Overload


TableSplitPanel Fields

[image] [image]

.NET Framework Class Library
TableSplitPanel Fields
TableSplitPanel Class See Also Send Feedback

The TableSplitPanel type exposes the following members.

Fields

Name | Description
Panels | Двумерный массив панелей, каждый элемент которого представляет собой 1 ячейку (класс TableCellPanel). Первый индекс в массиве - индекс столбца, второй - строки.

See Also

TableSplitPanel Class


Panels Field

[image]

.NET Framework Class Library
TableSplitPanel..::.Panels Field
TableSplitPanel Class See Also Send Feedback

Двумерный массив панелей, каждый элемент которого представляет собой 1 ячейку (класс TableCellPanel). Первый индекс в массиве - индекс столбца, второй - строки.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Panels As TableCellPanel(,)
C#
public readonly TableCellPanel[,] Panels
Visual C++
public:
initonly array<TableCellPanel^,2>^ Panels
JavaScript
panels

See Also

TableSplitPanel Class


TableSplitPanel Methods

[image] [image]

.NET Framework Class Library
TableSplitPanel Methods
TableSplitPanel Class See Also Send Feedback

The TableSplitPanel type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | (Inherited from Control.)
Contains | (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Control.)
CreateControl | (Inherited from Control.)
CreateControlsInstance | (Inherited from Control.)
CreateGraphics | (Inherited from Control.)
CreateHandle | (Inherited from Control.)
CreateObjRef | (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Control.)
DestroyHandle | (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | (Inherited from Control.)
DrawToBitmap | (Inherited from Control.)
EndInvoke | (Inherited from Control.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Component.)
FindForm | (Inherited from Control.)
Focus | (Inherited from Control.)
ForEach | Цикл по всем ячейкам.
GetAccessibilityObjectById | (Inherited from Control.)
GetAutoSizeMode | (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | (Inherited from Control.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetNextControl | (Inherited from Control.)
GetPreferredSize | (Inherited from Control.)
GetScaledBounds | (Inherited from Control.)
GetScrollState | (Inherited from ScrollableControl.)
GetService | (Inherited from Component.)
GetStyle | (Inherited from Control.)
GetTopLevel | (Inherited from Control.)
GetType | (Inherited from Object.)
Hide | (Inherited from Control.)
InitializeLifetimeService | (Inherited from MarshalByRefObject.)
InitLayout | (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | (Inherited from Control.)
InvokeLostFocus | (Inherited from Control.)
InvokeOnClick | (Inherited from Control.)
InvokePaint | (Inherited from Control.)
InvokePaintBackground | (Inherited from Control.)
IsInputChar | (Inherited from Control.)
IsInputKey | (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | (Inherited from Control.)
OnAutoSizeChanged | (Inherited from Control.)
OnAutoValidateChanged | (Inherited from ContainerControl.)
OnBackColorChanged | (Inherited from Control.)
OnBackgroundImageChanged | (Inherited from Control.)
OnBackgroundImageLayoutChanged | (Inherited from Control.)
OnBindingContextChanged | (Inherited from Control.)
OnCausesValidationChanged | (Inherited from Control.)
OnChangeUICues | (Inherited from Control.)
OnClick | (Inherited from Control.)
OnClientSizeChanged | (Inherited from Control.)
OnContextMenuChanged | (Inherited from Control.)
OnContextMenuStripChanged | (Inherited from Control.)
OnControlAdded | (Inherited from Control.)
OnControlRemoved | (Inherited from Control.)
OnCreateControl | (Inherited from ContainerControl.)
OnCursorChanged | (Inherited from Control.)
OnDockChanged | (Inherited from Control.)
OnDoubleClick | (Inherited from Control.)
OnDragDrop | (Inherited from Control.)
OnDragEnter | (Inherited from Control.)
OnDragLeave | (Inherited from Control.)
OnDragOver | (Inherited from Control.)
OnEnabledChanged | (Inherited from Control.)
OnEnter | (Inherited from Control.)
OnFontChanged | (Inherited from ContainerControl.)
OnForeColorChanged | (Inherited from Control.)
OnGiveFeedback | (Inherited from Control.)
OnGotFocus | (Inherited from Control.)
OnHandleCreated | (Inherited from Control.)
OnHandleDestroyed | (Inherited from Control.)
OnHelpRequested | (Inherited from Control.)
OnImeModeChanged | (Inherited from Control.)
OnInvalidated | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyPress | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | (Inherited from Control.)
OnLocationChanged | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMarginChanged | (Inherited from Control.)
OnMouseCaptureChanged | (Inherited from Control.)
OnMouseClick | (Inherited from Control.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseHover | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseUp | (Inherited from Control.)
OnMouseWheel | (Inherited from ScrollableControl.)
OnMove | (Inherited from Control.)
OnNotifyMessage | (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | (Inherited from Control.)
OnParentBackgroundImageChanged | (Inherited from Control.)
OnParentBindingContextChanged | (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | (Inherited from Control.)
OnParentEnabledChanged | (Inherited from Control.)
OnParentFontChanged | (Inherited from Control.)
OnParentForeColorChanged | (Inherited from Control.)
OnParentRightToLeftChanged | (Inherited from Control.)
OnParentVisibleChanged | (Inherited from Control.)
OnPreviewKeyDown | (Inherited from Control.)
OnPrint | (Inherited from Control.)
OnQueryContinueDrag | (Inherited from Control.)
OnRegionChanged | (Inherited from Control.)
OnResize | (Inherited from Control.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | (Inherited from ScrollableControl.)
OnSizeChanged | (Inherited from Control.)
OnStyleChanged | (Inherited from Control.)
OnSystemColorsChanged | (Inherited from Control.)
OnTabIndexChanged | (Inherited from Control.)
OnTabStopChanged | (Inherited from Control.)
OnTextChanged | (Inherited from Control.)
OnValidated | (Inherited from Control.)
OnValidating | (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | (Inherited from Control.)
PointToScreen | (Inherited from Control.)
PreProcessControlMessage | (Inherited from Control.)
PreProcessMessage | (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | (Inherited from Control.)
ProcessKeyMessage | (Inherited from Control.)
ProcessKeyPreview | (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | (Inherited from ContainerControl.)
RaiseDragEvent | (Inherited from Control.)
RaiseKeyEvent | (Inherited from Control.)
RaiseMouseEvent | (Inherited from Control.)
RaisePaintEvent | (Inherited from Control.)
RecreateHandle | (Inherited from Control.)
RectangleToClient | (Inherited from Control.)
RectangleToScreen | (Inherited from Control.)
Refresh | (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | (Inherited from Control.)
RtlTranslateHorizontal | (Inherited from Control.)
RtlTranslateLeftRight | (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | (Inherited from ScrollableControl.)
ScrollToControl | (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | (Inherited from Control.)
SendToBack | (Inherited from Control.)
SetAutoScrollMargin | (Inherited from ScrollableControl.)
SetAutoSizeMode | (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Control.)
SetClientSizeCore | (Inherited from Control.)
SetDisplayRectLocation | (Inherited from ScrollableControl.)
SetScrollState | (Inherited from ScrollableControl.)
SetStyle | (Inherited from Control.)
SetTopLevel | (Inherited from Control.)
SetVisibleCore | (Inherited from Control.)
Show | (Inherited from Control.)
SizeFromClientSize | (Inherited from Control.)
SuspendLayout | (Inherited from Control.)
ToString | (Inherited from Component.)
Update | (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | (Inherited from ContainerControl.)
UpdateStyles | (Inherited from Control.)
UpdateZOrder | (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from ContainerControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TableSplitPanel Class


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.AccessibilityNotifyClients Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


BeginInvoke Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.BeginInvoke Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Dispose Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Dispose Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

TableSplitPanel Class
TableSplitPanel Members


ForEach Method

[image]

.NET Framework Class Library
TableSplitPanel..::.ForEach Method
TableSplitPanel Class See Also Send Feedback

Цикл по всем ячейкам.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Sub ForEach ( _
    action As Action(Of TableCellPanel) _
)
C#
public void ForEach(
    Action<TableCellPanel> action
)
Visual C++
public:
void ForEach(
    Action<TableCellPanel^>^ action
)
JavaScript
function forEach(action);

Parameters

action
Type: System..::.Action<(Of <( TableCellPanel >)>)
Действие.

See Also

TableSplitPanel Class


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.GetChildAtPoint Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Invalidate Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Invalidate Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | (Inherited from Control.)
Invalidate(Region) | (Inherited from Control.)
Invalidate(Boolean) | (Inherited from Control.)
Invalidate(Rectangle) | (Inherited from Control.)
Invalidate(Region, Boolean) | (Inherited from Control.)
Invalidate(Rectangle, Boolean) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Invoke Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Invoke Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.MemberwiseClone Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

TableSplitPanel Class
TableSplitPanel Members


PerformLayout Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.PerformLayout Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | (Inherited from Control.)
PerformLayout(Control, String) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


ResumeLayout Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.ResumeLayout Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | (Inherited from Control.)
ResumeLayout(Boolean) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.RtlTranslateAlignment Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Scale Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Scale Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Select Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Select Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Select()()() | (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TableSplitPanel Class
TableSplitPanel Members


SetBounds Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.SetBounds Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


UpdateBounds Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.UpdateBounds Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)

See Also

TableSplitPanel Class
TableSplitPanel Members


Validate Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.Validate Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | (Inherited from ContainerControl.)
Validate(Boolean) | (Inherited from ContainerControl.)

See Also

TableSplitPanel Class
TableSplitPanel Members


ValidateChildren Method

[image] [image]

.NET Framework Class Library
TableSplitPanel..::.ValidateChildren Method
TableSplitPanel Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from ContainerControl.)
ValidateChildren(ValidationConstraints) | (Inherited from ContainerControl.)

See Also

TableSplitPanel Class
TableSplitPanel Members


TableSplitPanel Properties

[image] [image]

.NET Framework Class Library
TableSplitPanel Properties
TableSplitPanel Class See Also Send Feedback

The TableSplitPanel type exposes the following members.

Properties

Name | Description
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
ActiveControl | (Inherited from ContainerControl.)
AllowDrop | (Inherited from Control.)
Anchor | (Inherited from Control.)
AutoScaleDimensions | (Inherited from ContainerControl.)
AutoScaleFactor | (Inherited from ContainerControl.)
AutoScaleMode | (Inherited from ContainerControl.)
AutoScroll | (Inherited from ScrollableControl.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Control.)
AutoValidate | (Inherited from ContainerControl.)
BackColor | (Inherited from Control.)
BackgroundImage | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Control.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
Controls | (Inherited from Control.)
Created | (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Cursor | (Inherited from Control.)
DataBindings | (Inherited from Control.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Control.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Control.)
DesignMode | (Inherited from Component.)
DisplayRectangle | (Inherited from ScrollableControl.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoubleBuffered | (Inherited from Control.)
Enabled | (Inherited from Control.)
Events | (Inherited from Component.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
Handle | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
ImeMode | (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsMirrored | (Inherited from Control.)
LayoutEngine | (Inherited from Control.)
Left | (Inherited from Control.)
Location | (Inherited from Control.)
Margin | (Inherited from Control.)
MaximumSize | (Inherited from Control.)
MinimumSize | (Inherited from Control.)
Name | (Inherited from Control.)
Padding | (Inherited from Control.)
Parent | (Inherited from Control.)
ParentForm | (Inherited from ContainerControl.)
PreferredSize | (Inherited from Control.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
Region | (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | (Inherited from Control.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
ScaleChildren | (Inherited from Control.)
ShowFocusCues | (Inherited from Control.)
ShowKeyboardCues | (Inherited from Control.)
Site | (Inherited from Control.)
Size | (Inherited from Control.)
SplitterColor | Цвет фона элементов управления splitter, разделяющих строки и столбцы ячеек.
SplitterDragColor | Цвет (в момент перетаскивания) элементов управления splitter, разделяющих строки и столбцы ячеек.
TabIndex | (Inherited from Control.)
TabStop | (Inherited from Control.)
Tag | (Inherited from Control.)
Text | (Inherited from Control.)
Top | (Inherited from Control.)
TopLevelControl | (Inherited from Control.)
UseWaitCursor | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TableSplitPanel Class


SplitterColor Property

[image]

.NET Framework Class Library
TableSplitPanel..::.SplitterColor Property
TableSplitPanel Class See Also Send Feedback

Цвет фона элементов управления splitter, разделяющих строки и столбцы ячеек.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Property SplitterColor As Color
C#
public Color SplitterColor { get; set; }
Visual C++
public:
property Color SplitterColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_splitterColor();
function set_splitterColor(value);

See Also

TableSplitPanel Class


SplitterDragColor Property

[image]

.NET Framework Class Library
TableSplitPanel..::.SplitterDragColor Property
TableSplitPanel Class See Also Send Feedback

Цвет (в момент перетаскивания) элементов управления splitter, разделяющих строки и столбцы ячеек.

Namespace: TableSplitControl
Assembly: TableSplitControl (in TableSplitControl.dll)

Syntax

Visual Basic (Declaration)
Public Property SplitterDragColor As Color
C#
public Color SplitterDragColor { get; set; }
Visual C++
public:
property Color SplitterDragColor {
    Color get ();
    void set (Color value);
}
JavaScript
function get_splitterDragColor();
function set_splitterDragColor(value);

See Also

TableSplitPanel Class


TableSplitPanel Events

[image] [image]

.NET Framework Class Library
TableSplitPanel Events
TableSplitPanel Class See Also Send Feedback

The TableSplitPanel type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from Control.)
AutoValidateChanged | (Inherited from ContainerControl.)
BackColorChanged | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BindingContextChanged | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientSizeChanged | (Inherited from Control.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlRemoved | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
Disposed | (Inherited from Component.)
DockChanged | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
Enter | (Inherited from Control.)
FontChanged | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HelpRequested | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
Invalidated | (Inherited from Control.)
KeyDown | (Inherited from Control.)
KeyPress | (Inherited from Control.)
KeyUp | (Inherited from Control.)
Layout | (Inherited from Control.)
Leave | (Inherited from Control.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MarginChanged | (Inherited from Control.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
Resize | (Inherited from Control.)
RightToLeftChanged | (Inherited from Control.)
Scroll | (Inherited from ScrollableControl.)
SizeChanged | (Inherited from Control.)
StyleChanged | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndexChanged | (Inherited from Control.)
TabStopChanged | (Inherited from Control.)
TextChanged | (Inherited from Control.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)

See Also

TableSplitPanel Class